Unable to run Classical Builder


advanced search

Message boards : Classical Builder : Unable to run Classical Builder

Reply to this thread
Subscribe to this thread
Sort
AuthorMessage
[BAT] tutta55 User profile image
Avatar
private message
Joined: Feb 26, 2006
Posts: 104
ID: 485
Credit: 4,072,468
RAC: 293
Message 1523 - Posted 13 Mar 2007 16:17:03 UTC

I tried to run Classical Builder in Vista.

Observation 1: Starting the application makes Vista disable its Aero effects.

Observation 2: The programs fails to start. I get:

An error occurred while launching/running the application.

Title: Classical Builder
Vendor: Leiden University
Category: Launch File Error

Could not parse launch file. Error at line 82.


and in the Java console exception window:

JNLParseException[ Could not parse launch file. Error at line 82.]

at com.sun.javaws.xml.XMLParser.parse(Unknown Source)

at com.sun.javaws.jnl.XMLFormat.parse(Unknown Source)

at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)

at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)

at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)

at com.sun.javaws.LaunchDownload.getUpdatedLaunchDesc(Unknown Source)

at com.sun.javaws.Launcher.downloadResources(Unknown Source)

at com.sun.javaws.Launcher.handleApplicationDesc(Unknown Source)

at com.sun.javaws.Launcher.handleLaunchFile(Unknown Source)

at com.sun.javaws.Launcher.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

____________

BOINC.BE: For Belgians who love the smell of glowing red cpu's in the morning
Tutta55's Lair

m.somers User profile image
Forum moderator
Project administrator
Project developer
Project tester
Volunteer developer
Volunteer tester
Project scientist
Avatar
private message
Joined: Nov 14, 2005
Posts: 662
ID: 1
Credit: 1,417,572
RAC: 2
Message 1524 - Posted 13 Mar 2007 18:28:33 UTC

Oops my bad... I forgot to update an URL... Done ... Works now here at home on XP ;-).



m.



____________
M.F. Somers

[BAT] tutta55 User profile image
Avatar
private message
Joined: Feb 26, 2006
Posts: 104
ID: 485
Credit: 4,072,468
RAC: 293
Message 1525 - Posted 13 Mar 2007 23:31:11 UTC - in response to Message ID 1524.

Oops my bad... I forgot to update an URL... Done ... Works now here at home on XP ;-).



m.


I will give it another go tomorrow.
____________

BOINC.BE: For Belgians who love the smell of glowing red cpu's in the morning
Tutta55's Lair

[BAT] tutta55 User profile image
Avatar
private message
Joined: Feb 26, 2006
Posts: 104
ID: 485
Credit: 4,072,468
RAC: 293
Message 1526 - Posted 14 Mar 2007 8:56:34 UTC

I'm sad to say I can't get it to work on my Vista machine. First I did several attempts to launch the app, during which each time some part was downloaded or updated (now jre 1.6.0 is installed) Each time these attempts ended in a message that a file was missing, or something just hung. Gradually I got further and further. Vista also told me it had to apply "compatibility settings" to the application. Now I am finally able to launch, and I briefly see a window with 3 black rectangular zones in it, but after a second or two it disappears.

I can give it a spin under XP at home. To get it running under Vista, you might have some work on your hands. I can tell. Been there for my company's own apps. Not Java unfortunately, so I can't help on that.
____________

BOINC.BE: For Belgians who love the smell of glowing red cpu's in the morning
Tutta55's Lair

m.somers User profile image
Forum moderator
Project administrator
Project developer
Project tester
Volunteer developer
Volunteer tester
Project scientist
Avatar
private message
Joined: Nov 14, 2005
Posts: 662
ID: 1
Credit: 1,417,572
RAC: 2
Message 1527 - Posted 14 Mar 2007 8:59:05 UTC

Probably you need to check if Java3D is correctly installed and that you have an OpenGL 1.2 capable driver for your videocard too...

Well, that was for me the issue a week or so ago... On the mac, howvere, it works out of the box and after I installed java3D and made sure I had the latest video drivers with OpenGL 1.2 support installed on XP, it worked like a charm on windows too...


m.



____________
M.F. Somers

[BAT] tutta55 User profile image
Avatar
private message
Joined: Feb 26, 2006
Posts: 104
ID: 485
Credit: 4,072,468
RAC: 293
Message 1528 - Posted 14 Mar 2007 9:58:55 UTC

I have installed Java3D. As for OpenGL, there are a number of complications in Vista, it seems. See http://www.opengl.org/pipeline/article/vol003_7/. I'm not at all sure that the application as it is will work for Vista.
____________

BOINC.BE: For Belgians who love the smell of glowing red cpu's in the morning
Tutta55's Lair

[BAT] tutta55 User profile image
Avatar
private message
Joined: Feb 26, 2006
Posts: 104
ID: 485
Credit: 4,072,468
RAC: 293
Message 1529 - Posted 14 Mar 2007 23:31:20 UTC

On my XP at home I got it to run without problems. I made a small example. Now I just have to figure out how I use it with the standalone application.


Hello-o. Am I the only one trying this?

Ageless User profile image
Forum moderator
Avatar
private message
Joined: Feb 15, 2006
Posts: 88
ID: 183
Credit: 27,416
RAC: 79
Message 1530 - Posted 15 Mar 2007 1:45:46 UTC

I'm wondering if it is a CPU intensive or non-intensive application? If intensive, what priority does it run at?
____________
Jord

m.somers User profile image
Forum moderator
Project administrator
Project developer
Project tester
Volunteer developer
Volunteer tester
Project scientist
Avatar
private message
Joined: Nov 14, 2005
Posts: 662
ID: 1
Credit: 1,417,572
RAC: 2
Message 1531 - Posted 15 Mar 2007 7:24:15 UTC
Last modified: 15 Mar 2007 7:35:06 UTC

Hi there, nice that you managed to run it on XP... To try the example you made, just download the standalone executable and drag your saved input on it... If all goes we you are running a simulation then... If nothing happens, try to use the command "GUL_ClassicalDynamics_Windows.exe testfilename" and see the error messages... You could start of simply by downloading an example and drag that on the app first to check...

Oh and the Classical-Builder is nothing but a GUI to make input files for the main app of this project. This project allows you to submit your own calcs. for that app, remember... So with the builder, you can make an input more easily and use that to submit... snappie? Which means that the Builder is not CPU-intesive or anything like that as it does not do the simulation itself...


m.


____________
M.F. Somers

[BAT] tutta55 User profile image
Avatar
private message
Joined: Feb 26, 2006
Posts: 104
ID: 485
Credit: 4,072,468
RAC: 293
Message 1532 - Posted 15 Mar 2007 22:10:51 UTC

Ok, Mark. I tried out my small example (just 3 particles and 2 interactions). It doesn't run. If I start from the command line I get "Error reading inputfile 'testje.cbs' in line 25 !"

Should I e-mail you the example? If so, at the e-mail address with domain starting with "chem"?
____________

BOINC.BE: For Belgians who love the smell of glowing red cpu's in the morning
Tutta55's Lair

m.somers User profile image
Forum moderator
Project administrator
Project developer
Project tester
Volunteer developer
Volunteer tester
Project scientist
Avatar
private message
Joined: Nov 14, 2005
Posts: 662
ID: 1
Credit: 1,417,572
RAC: 2
Message 1534 - Posted 16 Mar 2007 7:05:08 UTC

What you wish... You can also post line 25 here and I can have a look at it then ;-)...

m.


____________
M.F. Somers

[BAT] tutta55 User profile image
Avatar
private message
Joined: Feb 26, 2006
Posts: 104
ID: 485
Credit: 4,072,468
RAC: 293
Message 1535 - Posted 16 Mar 2007 7:59:43 UTC - in response to Message ID 1534.

What you wish... You can also post line 25 here and I can have a look at it then ;-)...

m.



I will e-mail it, because when I open the file in notepad I only see 2 lines. Strange. Will do so tonight. Because for once I tried something out at home :p
____________

BOINC.BE: For Belgians who love the smell of glowing red cpu's in the morning
Tutta55's Lair

KSMarksPsych User profile image
Avatar
private message
Joined: Feb 15, 2006
Posts: 40
ID: 153
Credit: 5,050
RAC: 15
Message 1536 - Posted 17 Mar 2007 0:27:39 UTC - in response to Message ID 1529.

Hello-o. Am I the only one trying this?


I swear I'll play with it this weekend. I've got one other thing to test out first.
____________
Kathryn :o)
The BOINC FAQ Service
The Unofficial BOINC Wiki
The Trac System
More BOINC information than you can shake a stick of RAM at.

JLDun
Avatar
private message
Joined: Nov 30, 2007
Posts: 1
ID: 11219
Credit: 1,027
RAC: 36
Message 1980 - Posted 5 Jan 2008 8:15:42 UTC


____________

DramaKing
private message
Joined: Jan 7, 2008
Posts: 3
ID: 12148
Credit: 283,096
RAC: 265
Message 1982 - Posted 8 Jan 2008 3:26:49 UTC

Ha ha. I consistently get the same exact error when I try to run CB. It occurs on both XP and Vista with JRE 1.6 and Java3D.

DramaKing
private message
Joined: Jan 7, 2008
Posts: 3
ID: 12148
Credit: 283,096
RAC: 265
Message 1983 - Posted 8 Jan 2008 3:34:54 UTC

Ha ha. I consistently get the same exact error when I try to run CB. It occurs on both XP and Vista with JRE 1.6 and Java3D.

DramaKing
private message
Joined: Jan 7, 2008
Posts: 3
ID: 12148
Credit: 283,096
RAC: 265
Message 1984 - Posted 8 Jan 2008 3:39:35 UTC

Ha ha. I consistently get the same exact error when I try to run CB. It occurs on both XP and Vista with JRE 1.6 and Java3D.

adrianxw
Avatar
private message
Joined: Mar 8, 2006
Posts: 23
ID: 731
Credit: 244,226
RAC: 19
Message 1988 - Posted 16 Jan 2008 17:07:18 UTC
Last modified: 16 Jan 2008 17:07:42 UTC

Ignore.
____________
Wave upon wave of demented avengers march cheerfully out of obscurity into the dream.

m.somers User profile image
Forum moderator
Project administrator
Project developer
Project tester
Volunteer developer
Volunteer tester
Project scientist
Avatar
private message
Joined: Nov 14, 2005
Posts: 662
ID: 1
Credit: 1,417,572
RAC: 2
Message 1998 - Posted 18 Jan 2008 10:20:08 UTC

Hi, found out the problem; the webstart checks the signed certificate of the jar and the certificate had expired. Just run the .jar directly for the time being.. we should be having a version update pretty soon on the builder anyway so...


m.
____________
M.F. Somers

m.somers User profile image
Forum moderator
Project administrator
Project developer
Project tester
Volunteer developer
Volunteer tester
Project scientist
Avatar
private message
Joined: Nov 14, 2005
Posts: 662
ID: 1
Credit: 1,417,572
RAC: 2
Message 2043 - Posted 7 Feb 2008 6:45:25 UTC

Should be able to run the builder again. Right now you'll get a pre-release (alpha) verion of CB 2.0 thoug with some new fancy options! We are currently hard at work to make a new full release of CB 2.0! New options options in 2.0 will make it possible to open multiple files, directly run the calculation locally and here on the grid and will have an improved UI.

m.


____________
M.F. Somers

Reply to this thread

Message boards : Classical Builder : Unable to run Classical Builder



Return to Leiden Classical main page


Copyright © 2017 Leiden University - Leiden Institute of Chemistry - Theoretical Chemistry Department