ComputationError@Home


advanced search

Message boards : Leiden Classical : ComputationError@Home

Reply to this thread
Subscribe to this thread
Sort
AuthorMessage
Jeff Gu
Avatar
private message
Joined: Apr 9, 2006
Posts: 10
ID: 1065
Credit: 1,004,132
RAC: 65
Message 2451 - Posted 25 Jul 2009 20:29:22 UTC

I have a couple of 64-bit Linux machines (both quads) running 6.4.5 that have the same problem. ALL Leiden work units (running the Classical app, the Trajtou problem seems to be fixed) that error out immediately.

After letting gobs of them do this, I detached Leiden from those machines. Anyone else having this issue? The machines are experiencing no problems with any other projects.
____________
Jeff Gu
Guru Mountain DC Team

m.somers User profile image
Forum moderator
Project administrator
Project developer
Project tester
Volunteer developer
Volunteer tester
Project scientist
Avatar
private message
Joined: Nov 14, 2005
Posts: 662
ID: 1
Credit: 1,417,572
RAC: 2
Message 2452 - Posted 27 Jul 2009 7:23:02 UTC
Last modified: 27 Jul 2009 7:23:22 UTC

This is what I found in the error log:

<stderr_txt>
classical_5.56_x86_64-pc-linux-gnu.exe: error while loading shared libraries: libglut.so.3: cannot open shared object file: No such file or directory

</stderr_txt>


Check out

http://boinc.gorlaeus.net/Graphical_libs.php

m.
____________
M.F. Somers

Skip Da Shu
Avatar
private message
Joined: Apr 29, 2007
Posts: 23
ID: 5991
Credit: 857,469
RAC: 56
Message 2458 - Posted 31 Jul 2009 5:56:23 UTC

Yup, same here v6.4.5, Linux 64b Ubuntu v9.04

31-Jul-2009 00:51:20 [Leiden Classical] Started download of classical.water_molecules_BIG_64_898976128_1245057971_74141
31-Jul-2009 00:51:22 [Leiden Classical] Finished download of classical.water_molecules_BIG_64_898976128_1245057971_74141
31-Jul-2009 00:51:23 [Leiden Classical] Starting wu_898976128_1245057971_74141_2
31-Jul-2009 00:51:23 [Leiden Classical] Starting task wu_898976128_1245057971_74141_2 using classical version 556
31-Jul-2009 00:51:24 [Leiden Classical] Computation for task wu_898976128_1245057971_74141_2 finished
31-Jul-2009 00:51:24 [Leiden Classical] Output file wu_898976128_1245057971_74141_2_0 for task wu_898976128_1245057971_74141_2 absent
31-Jul-2009 00:51:24 [Leiden Classical] Output file wu_898976128_1245057971_74141_2_1 for task wu_898976128_1245057971_74141_2 absent

Skip Da Shu
Avatar
private message
Joined: Apr 29, 2007
Posts: 23
ID: 5991
Credit: 857,469
RAC: 56
Message 2459 - Posted 31 Jul 2009 6:16:00 UTC
Last modified: 31 Jul 2009 6:19:21 UTC

This is dup thread...

Testing now to see if this goes away after installing freeglut from repository (Ubunutu/Debian).

EDIT: Yup worked. Installed freeglut3, restarted boinc, downloaded a new WU and it's running (a couple minutes now so the immediate crash is at least fixed with this).

Jeff Gu
Avatar
private message
Joined: Apr 9, 2006
Posts: 10
ID: 1065
Credit: 1,004,132
RAC: 65
Message 2460 - Posted 31 Jul 2009 8:26:29 UTC

Yeah, same here... installed GLUT and problem went away... :)

____________
Jeff Gu
Guru Mountain DC Team

Lloyd M.
private message
Joined: Mar 7, 2007
Posts: 2
ID: 4711
Credit: 293,163
RAC: 298
Message 2525 - Posted 15 Nov 2009 22:38:19 UTC

I had a similar problem - a CLI Ubuntu box that ran several projects just fine, but would error out immediately, result 127 on Leiden (I racked up about 40 WU's before I set it to no more work). Turns out this project won't run unless you have GLUT. Kind of odd, because I think this is a graphic package and the box is a strictly CLI server, but there you have it.

Anyway, I installed FreeGLUT per: http://ubuntuforums.org/archive/index.php/t-345177.html , and Leiden seems to be running fine now.
____________

Reply to this thread

Message boards : Leiden Classical : ComputationError@Home



Return to Leiden Classical main page


Copyright © 2017 Leiden University - Leiden Institute of Chemistry - Theoretical Chemistry Department