computing problem with Ubuntu 9.10 64 bit/BOINC 6.10.17


advanced search

Questions and Answers : Unix/Linux : computing problem with Ubuntu 9.10 64 bit/BOINC 6.10.17

Reply to this thread
Subscribe to this thread
Sort
AuthorMessage
LAZA74
private message
Joined: Feb 16, 2007
Posts: 8
ID: 4207
Credit: 403,301
RAC: 103
Message 2515 - Posted 11 Nov 2009 17:31:31 UTC
Last modified: 11 Nov 2009 17:32:47 UTC

I hope this is NOT still a libstdc++5 problem...
In my repository is no more the 5-version - and libdc++6 installed.

What else can be the problem?
Installed Ubuntu new and got BOINC from getdeb.net.
QMC got also the same(?) problem, Spinhenge and WCG operate smoothly...

Edith: Sorry, forgot the CPU: AMD Phenom II
____________

[B^S] JoeB@KY
private message
Joined: Nov 28, 2008
Posts: 1
ID: 18456
Credit: 200,883
RAC: 95
Message 2558 - Posted 9 Mar 2010 20:05:20 UTC

I just installed the same OS in my Q9550 C2Q box, Ubuntu 9.10, 64 bit and now every Leiden WU ends up, "Computation Error"; no problems with any other BOINC Project. I tried detaching and reattaching; no difference, same end result.

Any ideas on what I should do next would be appreciated>

m.somers User profile image
Forum moderator
Project administrator
Project developer
Project tester
Volunteer developer
Volunteer tester
Project scientist
Avatar
private message
Joined: Nov 14, 2005
Posts: 662
ID: 1
Credit: 1,417,572
RAC: 2
Message 2559 - Posted 11 Mar 2010 8:23:13 UTC

Hi,

try and run 'ldd' on the executable on your system and see what you are missing...

m.

____________
M.F. Somers

LAZA74
private message
Joined: Feb 16, 2007
Posts: 8
ID: 4207
Credit: 403,301
RAC: 103
Message 2584 - Posted 3 May 2010 5:07:01 UTC - in response to Message ID 2559.

Hai all!

Seems to my an equal problem on an fresh installation of Lucid!


Hi,

try and run 'ldd' on the executable on your system and see what you are missing...

m.



Here is it:
/usr/bin$ ldd boinc
linux-vdso.so.1 => (0x00007fffac0ff000)
libcurl.so.4 => /usr/lib/libcurl.so.4 (0x00007fdf5ba54000)
libssl.so.0.9.8 => /lib/libssl.so.0.9.8 (0x00007fdf5b804000)
libcrypto.so.0.9.8 => /lib/libcrypto.so.0.9.8 (0x00007fdf5b473000)
libdl.so.2 => /lib/libdl.so.2 (0x00007fdf5b26f000)
libz.so.1 => /lib/libz.so.1 (0x00007fdf5b058000)
libpthread.so.0 => /lib/libpthread.so.0 (0x00007fdf5ae3a000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007fdf5ab26000)
libm.so.6 => /lib/libm.so.6 (0x00007fdf5a8a3000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00007fdf5a68b000)
libc.so.6 => /lib/libc.so.6 (0x00007fdf5a309000)
libidn.so.11 => /usr/lib/libidn.so.11 (0x00007fdf5a0d6000)
liblber-2.4.so.2 => /usr/lib/liblber-2.4.so.2 (0x00007fdf59ec7000)
libldap_r-2.4.so.2 => /usr/lib/libldap_r-2.4.so.2 (0x00007fdf59c7b000)
librt.so.1 => /lib/librt.so.1 (0x00007fdf59a73000)
libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0x00007fdf5983e000)
/lib64/ld-linux-x86-64.so.2 (0x00007fdf5bcb9000)
libresolv.so.2 => /lib/libresolv.so.2 (0x00007fdf59625000)
libsasl2.so.2 => /usr/lib/libsasl2.so.2 (0x00007fdf5940a000)
libgnutls.so.26 => /usr/lib/libgnutls.so.26 (0x00007fdf59168000)
libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0x00007fdf58ea4000)
libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0x00007fdf58c7d000)
libcom_err.so.2 => /lib/libcom_err.so.2 (0x00007fdf58a79000)
libkrb5support.so.0 => /usr/lib/libkrb5support.so.0 (0x00007fdf58871000)
libkeyutils.so.1 => /lib/libkeyutils.so.1 (0x00007fdf5866d000)
libtasn1.so.3 => /usr/lib/libtasn1.so.3 (0x00007fdf5845c000)
libgcrypt.so.11 => /lib/libgcrypt.so.11 (0x00007fdf581e4000)
libgpg-error.so.0 => /lib/libgpg-error.so.0 (0x00007fdf57fdf000)

$ uname -a
Linux Lucid 2.6.32-21-generic #32-Ubuntu SMP Fri Apr 16 08:09:38 UTC 2010 x86_64 GNU/Linux

$ boinc --version
6.10.17 x86_64-pc-linux-gnu

Which packet is still missed?

Thnaks in advance
LAZA
____________

m.somers User profile image
Forum moderator
Project administrator
Project developer
Project tester
Volunteer developer
Volunteer tester
Project scientist
Avatar
private message
Joined: Nov 14, 2005
Posts: 662
ID: 1
Credit: 1,417,572
RAC: 2
Message 2585 - Posted 3 May 2010 7:39:24 UTC

Euh; try and run 'ldd' on the leiden classical code on your machine. Download it from http://boinc.gorlaeus.net/download/classical_5.56_x86_64-pc-linux-gnu.exe or find it in your boinc directory tree. I bet you are missing one of the graphical libs (see http://boinc.gorlaeus.net/Graphical_libs.php).

m.
____________
M.F. Somers

rickvanderzwet
private message
Joined: Jul 20, 2010
Posts: 2
ID: 26688
Credit: 2,788
RAC: 86
Message 2616 - Posted 3 Aug 2010 22:18:25 UTC - in response to Message ID 2585.
Last modified: 3 Aug 2010 22:18:58 UTC

Euh; try and run 'ldd' on the leiden classical code on your machine. Download it from http://boinc.gorlaeus.net/download/classical_5.56_x86_64-pc-linux-gnu.exe or find it in your boinc directory tree. I bet you are missing one of the graphical libs (see http://boinc.gorlaeus.net/Graphical_libs.php).

m.



Same hardware setup, same problem. ldd shows no missing libraries AFAIK:

$ ldd classical_5.56_x86_64-pc-linux-gnu.exe
linux-vdso.so.1 => (0x00007fffc55ff000)
libm.so.6 => /lib/libm.so.6 (0x00007f78c03cd000)
libglut.so.3 => /usr/lib/libglut.so.3 (0x00007f78c0186000)
libGLU.so.1 => /usr/lib/libGLU.so.1 (0x00007f78bff14000)
libGL.so.1 => /usr/lib/libGL.so.1 (0x00007f78bfc0c000)
libXmu.so.6 => /usr/lib/libXmu.so.6 (0x00007f78bf9f3000)
libXt.so.6 => /usr/lib/libXt.so.6 (0x00007f78bf78d000)
libXext.so.6 => /usr/lib/libXext.so.6 (0x00007f78bf57b000)
libXi.so.6 => /usr/lib/libXi.so.6 (0x00007f78bf36b000)
libSM.so.6 => /usr/lib/libSM.so.6 (0x00007f78bf161000)
libICE.so.6 => /usr/lib/libICE.so.6 (0x00007f78bef46000)
libX11.so.6 => /usr/lib/libX11.so.6 (0x00007f78bec10000)
libpthread.so.0 => /lib/libpthread.so.0 (0x00007f78be9f2000)
libc.so.6 => /lib/libc.so.6 (0x00007f78be66f000)
libXxf86vm.so.1 => /usr/lib/libXxf86vm.so.1 (0x00007f78be469000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007f78be154000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00007f78bdf3d000)
libnvidia-tls.so.256.40 => /usr/lib/tls/libnvidia-tls.so.256.40 (0x00007f78bdd3b000)
libnvidia-glcore.so.256.40 => /usr/lib/libnvidia-glcore.so.256.40 (0x00007f78bc34c000)
libdl.so.2 => /lib/libdl.so.2 (0x00007f78bc148000)
libuuid.so.1 => /lib/libuuid.so.1 (0x00007f78bbf43000)
libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00007f78bbd26000)
/lib64/ld-linux-x86-64.so.2 (0x00007f78c0675000)
libXau.so.6 => /usr/lib/libXau.so.6 (0x00007f78bbb22000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00007f78bb91b000)



m.somers User profile image
Forum moderator
Project administrator
Project developer
Project tester
Volunteer developer
Volunteer tester
Project scientist
Avatar
private message
Joined: Nov 14, 2005
Posts: 662
ID: 1
Credit: 1,417,572
RAC: 2
Message 2621 - Posted 13 Aug 2010 8:07:33 UTC

H'mmm; and running the executable; does that work?


m.
____________
M.F. Somers

rickvanderzwet
private message
Joined: Jul 20, 2010
Posts: 2
ID: 26688
Credit: 2,788
RAC: 86
Message 2623 - Posted 13 Aug 2010 17:57:07 UTC - in response to Message ID 2621.
Last modified: 13 Aug 2010 17:58:00 UTC

H'mmm; and running the executable; does that work?


Tried example http://boinc.gorlaeus.net/download/DownLoads/Examples/butane using:

/classical_5.56_x86_64-pc-linux-gnu.exe butane

I got get a picture with moving molecules if that's what you mean by working. Or will there be some other way to check for correct computation?

m.somers User profile image
Forum moderator
Project administrator
Project developer
Project tester
Volunteer developer
Volunteer tester
Project scientist
Avatar
private message
Joined: Nov 14, 2005
Posts: 662
ID: 1
Credit: 1,417,572
RAC: 2
Message 2624 - Posted 19 Aug 2010 9:20:05 UTC

Ah, but the moving molecule means that the Leiden Classical app is just working fine! It must be BOINC related now... Don't know what though, but you could try an older / newer client ?


m.
____________
M.F. Somers

LAZA74
private message
Joined: Feb 16, 2007
Posts: 8
ID: 4207
Credit: 403,301
RAC: 103
Message 2633 - Posted 5 Sep 2010 9:49:15 UTC - in response to Message ID 2621.

H'mmm; and running the executable; does that work?


m.



I got no more problems since i installed Lucid on my machine.
I also tried/installed the new 6.10.58 BOINC client from getdeb.net and still no problems...
So i hope this works for others, too.
LAZA
____________

Reply to this thread

Questions and Answers : Unix/Linux : computing problem with Ubuntu 9.10 64 bit/BOINC 6.10.17



Return to Leiden Classical main page


Copyright © 2017 Leiden University - Leiden Institute of Chemistry - Theoretical Chemistry Department