All my Mac WUs failing


advanced search

Message boards : Number crunching : All my Mac WUs failing

Reply to this thread
Subscribe to this thread
Sort
AuthorMessage
[AF>Le_Pommier] Jerome_C2005 User profile image
private message
Joined: Apr 20, 2008
Posts: 11
ID: 14142
Credit: 265,639
RAC: 112
Message 2939 - Posted 9 Jan 2015 21:51:16 UTC

Hi

All my WUs are now failing on my Mac (example :
http://boinc.gorlaeus.net/result.php?resultid=53820413)

It says

<core_client_version>7.4.26</core_client_version>
<![CDATA[
<message>
process got signal 5
</message>
<stderr_txt>
dyld: Library not loaded: /usr/X11R6/lib/libGLU.1.dylib
Referenced from: /Volumes/Macintosh HD/Users/Shared/BOINC Data/slots/4/../../projects/boinc.gorlaeus.net/classical_5.56_i686-apple-darwin.exe
Reason: image not found

</stderr_txt>
]]>

I think it's the first time I have such an issue with Leiden.

Any idea ?

Thanks

m.somers User profile image
Forum moderator
Project administrator
Project developer
Project tester
Volunteer developer
Volunteer tester
Project scientist
Avatar
private message
Joined: Nov 14, 2005
Posts: 662
ID: 1
Credit: 1,417,572
RAC: 2
Message 2940 - Posted 20 Jan 2015 12:46:49 UTC

Hi,

the clue is :

dyld: Library not loaded: /usr/X11R6/lib/libGLU.1.dylib


Please look at http://boinc.gorlaeus.net/Graphical_libs.php

m.
____________
M.F. Somers

[AF>Le_Pommier] Jerome_C2005 User profile image
private message
Joined: Apr 20, 2008
Posts: 11
ID: 14142
Credit: 265,639
RAC: 112
Message 2941 - Posted 20 Jan 2015 21:50:44 UTC

Thanks for the answer, though I'm not really sure how to do it :

- I have XQuartz installed already
- regarding the GLUT thingy, I really don't understand what can be done there
- I tried to "install" the MESA thingy, but it seems to be a collection of libraries, uncompiled ? I tried to follow the installation instructions for Mac OS X, but it fails

iMac-Famile-Cadet-2:move_to_boinc_dir jerome$ export MESASDK_ROOT=/Applications/mesasdk
iMac-Famile-Cadet-2:move_to_boinc_dir jerome$ source $MESASDK_ROOT/bin/mesasdk_init.sh
2015-01-20 22:42:46.969 system_profiler[18876:3330278] platformPluginDictionary: Can't get X86PlatformPlugin, return value 0
2015-01-20 22:42:46.971 system_profiler[18876:3330278] platformPluginDictionary: Can't get X86PlatformPlugin, return value 0

and anyway it says "Steps 4 and 5 need to be repeated each time you begin a new shell session"

all this is way too far away from a regular boinc project in order to be used by any standard cruncher... I'm afraid I won't invest more time if there isn't any "straight forward simple enough" solution.

Thanks

[AF>Le_Pommier] Jerome_C2005 User profile image
private message
Joined: Apr 20, 2008
Posts: 11
ID: 14142
Credit: 265,639
RAC: 112
Message 2942 - Posted 1 Feb 2015 18:50:59 UTC

After reading more on the MESA page I realized it requires XCode SDK and the version of XCode I had was not good with Yosemite, so I installed latest XCode, then the charity event was over so I opened again all my projects, I got a few Leiden WU and the first one did finish OK, cool !

[AF>Le_Pommier] Jerome_C2005 User profile image
private message
Joined: Apr 20, 2008
Posts: 11
ID: 14142
Credit: 265,639
RAC: 112
Message 2945 - Posted 18 Mar 2015 22:33:16 UTC
Last modified: 18 Mar 2015 22:34:36 UTC

Well now everything if failing with

<core_client_version>7.4.36</core_client_version>
<![CDATA[
<message>
process got signal 5
</message>
<stderr_txt>
dyld: Library not loaded: /usr/X11R6/lib/libGLU.1.dylib
Referenced from: /Volumes/Macintosh HD/Users/Shared/BOINC Data/slots/4/../../projects/boinc.gorlaeus.net/classical_5.56_i686-apple-darwin.exe
Reason: image not found

</stderr_txt>
]]>


I love those "process got signal X" error, sometimes it's "signal 4", now it is 5...

[AF>Le_Pommier] Jerome_C2005 User profile image
private message
Joined: Apr 20, 2008
Posts: 11
ID: 14142
Credit: 265,639
RAC: 112
Message 2946 - Posted 21 Mar 2015 16:00:59 UTC

All my WUs are still failing with the same error though I do have this library :

/opt/X11/lib/libGLU.1.dylib

Why this ? what can be done ?

m.somers User profile image
Forum moderator
Project administrator
Project developer
Project tester
Volunteer developer
Volunteer tester
Project scientist
Avatar
private message
Joined: Nov 14, 2005
Posts: 662
ID: 1
Credit: 1,417,572
RAC: 2
Message 2947 - Posted 24 Mar 2015 10:49:15 UTC - in response to Message ID 2946.

All my WUs are still failing with the same error though I do have this library :

/opt/X11/lib/libGLU.1.dylib

Why this ? what can be done ?




/opt/X11/lib/libGLU.1.dylib is not /usr/X11R6/lib/libGLU.1.dylib

m.
____________
M.F. Somers

[AF>Le_Pommier] Jerome_C2005 User profile image
private message
Joined: Apr 20, 2008
Posts: 11
ID: 14142
Credit: 265,639
RAC: 112
Message 2948 - Posted 24 Mar 2015 22:03:26 UTC

Ah OK maybe but I had installed all the XCode and MESA (that one I don't think I was ever able to "install it") stuff in the Mac in order to be able to run Leiden, and it was finally running, I have not changed it, so now the requirements have changed again (without notice) so what am I now supposed to do to be able to run it ??

I have Xcode 6.2 (6C131e) which is supposed to be the latest version available on the latest Mac OS X version... ?

Or are we supposed to install some source stuff and compile libraries and whatever geeky / dev techy stuff to be able to run Leiden ? I such case I'm afraid it's no more a boinc project for regular end user...

m.somers User profile image
Forum moderator
Project administrator
Project developer
Project tester
Volunteer developer
Volunteer tester
Project scientist
Avatar
private message
Joined: Nov 14, 2005
Posts: 662
ID: 1
Credit: 1,417,572
RAC: 2
Message 2949 - Posted 30 Mar 2015 11:51:40 UTC - in response to Message ID 2948.

Hi,

the requirements of the Leiden Classical app have not changed. What has changed is the default location where Apple puts the correct libGLU.1.dylib library. It used to be under /usr/X11R6, but now it is under /opt/X11.

So the simple solution is to try this:

ln -s /opt/X11 /usr/X11R6



m.
____________
M.F. Somers

[AF>Le_Pommier] Jerome_C2005 User profile image
private message
Joined: Apr 20, 2008
Posts: 11
ID: 14142
Credit: 265,639
RAC: 112
Message 2950 - Posted 3 Apr 2015 6:02:54 UTC
Last modified: 3 Apr 2015 6:03:38 UTC

Hi

I hadn't seen your answer : I created the link, I had to add a "sudo" on the Mac to be able to run it. Is this permanent and does it survive reboot ?

I don't think that I'll have any Leiden WU soon since l'AF is about to start its spring RAID (on 2 math projects), during 2 weeks.

I'll let you know when I crunch some.

Thanks.

[AF>Le_Pommier] Jerome_C2005 User profile image
private message
Joined: Apr 20, 2008
Posts: 11
ID: 14142
Credit: 265,639
RAC: 112
Message 2952 - Posted 8 May 2015 12:07:20 UTC

Just for information, it did work, thanks.

[AF>Le_Pommier] Jerome_C2005 User profile image
private message
Joined: Apr 20, 2008
Posts: 11
ID: 14142
Credit: 265,639
RAC: 112
Message 2971 - Posted 18 Jul 2015 10:45:04 UTC

Just for information, it worked until I had to reinstall Mac OS X completely, following a long list of issues that happened all of a sudden on my Mac (but luckily you can do that without affecting all your applications and setups system wide, that's cool), and then I forgot about this trick and I realized after some time that all my Leiden WUs were failing again, so I just reapplied the trick and it's working again.

So yes it's surviving reboots, but (logically, even though I didn't loose all my system and applications setup) not system reinstallation :)

Reply to this thread

Message boards : Number crunching : All my Mac WUs failing



Return to Leiden Classical main page


Copyright © 2017 Leiden University - Leiden Institute of Chemistry - Theoretical Chemistry Department